Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 4 days agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square23fedilinkarrow-up178arrow-down19
arrow-up169arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 4 days agomessage-square23fedilink
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up13arrow-down1·3 days agoBalls.suck() is the correct syntax.
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up5·3 days agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up9·edit-23 days agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up9·edit-23 days agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up13·3 days agoPython port: from ballsucker import suck suck()
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·3 days agoOr I didn’t using the correct naming convention!
minus-squareluciferofastora@lemmy.ziplinkfedilinkarrow-up2·3 days agoActually, it would be OOP.suck(ddplf.getBalls())
Balls.suck() is the correct syntax.
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!
Actually, it would be
OOP.suck(ddplf.getBalls())